Нема описа

Frédéric Guillot 56efd2eb3f Add workaround for non GMT dates (RFC822, RFC850, and RFC1123) пре 8 година
api 0925899cee Move API middleware and routes to api package пре 8 година
cli 6869c6fe6f Send cli errors to stderr пре 8 година
client 11dfcdd3d6 Fix typo in license header пре 8 година
config 87648490fd Make configurable the number of days to archive read items пре 8 година
crypto 11dfcdd3d6 Fix typo in license header пре 8 година
database a614f98063 Set arbitrary maximum size for tsvector column пре 8 година
errors 11dfcdd3d6 Fix typo in license header пре 8 година
fever a9f98adb07 Move Fever middleware and routes to fever package пре 8 година
http 6ae935309a Ignore JSON feeds from EnsureUnicode() пре 8 година
integration 9dc38a0803 Add missing package descriptions for GoDoc пре 8 година
locale 0b63e05fe2 Add Italian translation пре 8 година
logger 04220ca1e7 Remove date and time from log messages пре 8 година
model 234b3710d4 Fix golint import in travis.yml пре 8 година
oauth2 dc8668b904 Improve logging for OAuth2 callback пре 8 година
reader 56efd2eb3f Add workaround for non GMT dates (RFC822, RFC850, and RFC1123) пре 8 година
service 87648490fd Make configurable the number of days to archive read items пре 8 година
storage 012138179c Add function storage.UpdateFeedError() пре 8 година
template cf25efb4d9 Allow to switch between unread only and all entries on category/feed views пре 8 година
tests 11dfcdd3d6 Fix typo in license header пре 8 година
timer 11dfcdd3d6 Fix typo in license header пре 8 година
timezone 9dc38a0803 Add missing package descriptions for GoDoc пре 8 година
ui 078cd0050a Make sure that <strong> elements are bold пре 8 година
url d5ff4191b6 Improve unit tests in url package пре 8 година
vendor 59d8e9b95e Update dependencies пре 8 година
version 11dfcdd3d6 Fix typo in license header пре 8 година
worker 3e392dc3ae Change log level to debug when starting workers пре 8 година
.gitignore b51e7ea448 Add Makefile target for current OS and architecture пре 8 година
.travis.yml 234b3710d4 Fix golint import in travis.yml пре 8 година
ChangeLog 0be619355f Update ChangeLog пре 8 година
LICENSE 8ffb773f43 First commit пре 9 година
Makefile b51e7ea448 Add Makefile target for current OS and architecture пре 8 година
Procfile 41ce0a3b80 Make latest changes compatible with Heroku пре 8 година
README.md 25c12053a6 Typo in README.md пре 8 година
doc.go 11dfcdd3d6 Fix typo in license header пре 8 година
generate.go 59d8e9b95e Update dependencies пре 8 година
go.mod 59d8e9b95e Update dependencies пре 8 година
go.sum 59d8e9b95e Update dependencies пре 8 година
main.go dbcc5d8a97 Use canonical imports пре 8 година
miniflux.1 1315282c7f Add the possiblity to listen on Unix socket пре 8 година

README.md

Miniflux 2

Build Status GoDoc Documentation Status

Miniflux is a minimalist and opinionated feed reader:

  • Written in Go (Golang)
  • Works only with Postgresql
  • Doesn't use any ORM
  • Doesn't use any complicated framework
  • Use only modern vanilla Javascript (ES6 and Fetch API)
  • Single binary compiled statically without dependency
  • The number of features is voluntarily limited

It's simple, fast, lightweight and super easy to install.

Official website: https://miniflux.app

Documentation

The Miniflux documentation is available here: https://docs.miniflux.app/ (Man page)

Screenshots

Default theme:

Default theme

Dark theme when using keyboard navigation:

Dark theme

Credits